Releases
31.0.0
What's Changed
Breaking Changes 🛠
848e666 feat(advisor)!: Migrate the advisor to the new plugin API
dd90907 refactor!: Move PackageConfigurationProvider
to API module
90accbb refactor!: Move PackageCurationProvider
from model to plugin API
3c8b32a refactor!: Move config helpers from model
to new config-utils
module
89467d9 refactor(analyzer)!: Move PackageManagerDependencyHandler
to the root
4c7c9fc refactor(analyzer)!: Turn conversion functions into extensions
bd4e76e refactor(common-utils)!: Remove the force
argument from delete functions
e785545 refactor(model)!: Remove PackageConfigurationProvider
from OrtResult
1e5ae99 refactor(ort-utils)!: Remove the fallback to read uncompressed files
6636764 refactor(osv-client)!: Remove an unused constructor
f787654 refactor(osv-client)!: Remove the Server
enum
4f870c2 refactor(package-configuration-providers)!: Migrate to new plugin API
2a8ca2f refactor(package-configuration-providers)!: Remove unused EMPTY constant
934c6aa refactor(package-curation-providers)!: Migrate to the new plugin API
d782466 refactor(plugins-api)!: Make PluginDescriptor.id
the first argument
d15eaa1 refactor(plugins-api)!: Rename PluginDescriptor.className
to id
9b13596 refactor(plugins-api)!: Rename PluginDescriptor.name
to displayName
Bug Fixes 🐞
5d11ab0 advisors: Make configuration properties secrets
a477ded common-utils: Use the Path
API to delete files
ed095a6 compiler: Fix an error message
f991e15 ort-utils: Fix handling of LocalFileStorage.transformPath()
New Features 🎉
29468d0 compiler: Add the descriptor to the factory companion object
35d18a6 compiler: Allow multiple plugins of the same type in a project
e15091c compiler: Remove the parent class name suffix from the plugin id
1e0cdfe docker: Replace Syft for Docker own Scout SBOM generator
29a108a model: Check if an archive exists before trying to download it
71983f1 plugins: Add a new plugin API with symbol processing
5804107 plugins-api: Generate a JSON representation of the plugin spec
Build 🐘 & CI ⚙️
c01b6c8 detekt-rules: Fix the import check for a single dotless import
90a570d gradle: Fix applying the dependency analysis plugin
adbc676 package-managers: Make dependencies on GitCommand
explicit
b82a5c1 Introduce a convention plugin for plugins
1e9ae8a Rename the convention for plugin parent projects
3e94f07 github: Remove an unnecessary outdated parameter
627296b github: Remove the separate Gradle wrapper validation
Chores 🔧
2b8463d package-managers: Make gradlew
of test projects executable
954eb96 plugins: Use the companion object descriptor
s
97a81dd reuse: Migrate from dep5 to TOML format
Dependency Updates 🚀
6be1533 update actions/setup-python digest to f677139
cf72d14 update dependency com.autonomousapps.dependency-analysis to v2.0.1
c737daf update dependency prism-react-renderer to v2.4.0
0cdbc49 update github/codeql-action digest to 4dd1613
43c8a20 update gradle/actions digest to 16bf8bc
Documentation 📖
a4d249f downloader: Further improve a log message to include the revision
4da006b plugins-api: Fix docs for PluginDescriptor
properties
Refactorings 🚜
fdd90ca analyzer: Split package manager dependency classes across files
01a200e carthage: Trivially port from Jackson to KxS
78154d8 common-utils: Move recursive deletion tests to funTest
ab12481 common-utils: Move several tests to funTest
b67936d compiler: Use singleOrNull()
to simplify code
cb15705 gradle: Move OrtDependency
extension functions to the model
fbc786d gradle: Turn extension functions into properties
0e3900d gradle-inspector: Make use of OrtDependency
extensions
080b303 gradle-inspector: Migrate the code to use the dependency graph
814e56e plugins: Move KSP compiler to separate project
40e0133 plugins-api: Add default value for PluginDescriptor.options
4dd5a49 plugins-api: Separate plugin analysis from code generation
2401bf2 pub: Extract constants for the scope names
b42f894 pub: Remove a code redundancy from the construction of scopes
28c4149 pub: Remove an unnecessary for
loop and comment
d4fd3f1 pub: Use a data class for parsing the lockfile
a45bd86 pub: Use a shorter name for pkgInfoFromLockfile
Tests ✅
c8f2baa common-utils: Add a test for deleting files with bogus names
bb012f3 common-utils: Add a test for deleting read-only files
e0e8465 common-utils: Add a test for deleting with a base directory
8e05bcf ort-utils: Add missing tests for LocalFileStorage
b68e3b9 ort-utils: Reduce indentation in tests
af56607 ort-utils: Use function names for test containers
535ff62 osv: Update expected results
b0ae065 pub: Add a ()
to a test case name
bc98102 pub: Consistently use reader
b3e173a pub: Remove an unhandled property
ed29629 pub: Remove an unnecessary code comment
Other Changes 💡
d0840a6 Revert "test(osv): Update expected results"
You can’t perform that action at this time.