Skip to content
This repository was archived by the owner on May 9, 2022. It is now read-only.

Commit

Permalink
pyelftools: add python3 recipe and add python- prefix
Browse files Browse the repository at this point in the history
This has been implemented similarly to other python
packages in meta-openembedded/meta-python/recipes-devtools/python
which have a python-packagename.bb python3-packagename.bb and
python-packagename.inc with the common parts.

This now allows packages to depend on python3 variant of
pyelftools e.g. DEPENDS = python3-pyelftools-native

Signed-off-by: Peter Griffin <[email protected]>
  • Loading branch information
petegriffin authored and flihp committed Nov 22, 2019
1 parent e048e7e commit cdb0fd7
Show file tree
Hide file tree
Showing 3 changed files with 13 additions and 4 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -8,13 +8,10 @@ PR = "p0"
LICENSE = "PD"
S = "${WORKDIR}/git"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5ce2a2b07fca326bc7c146d10105ccfc"
RDEPENDS_${PN} = "python python-contextlib python-debugger python-pprint"
RDEPENDS_${PN}_class-native = "python"

SRC_URI += " \
git://github.com/eliben/pyelftools \
"
SRCREV = "master"

inherit setuptools

BBCLASSEXTEND = "native"
6 changes: 6 additions & 0 deletions recipes-devtools/pyelftools/python-pyelftools_git.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
inherit setuptools
require python-pyelftools.inc

RDEPENDS_${PN} = "python python-contextlib python-debugger python-pprint"
RDEPENDS_${PN}_class-native = "python"

6 changes: 6 additions & 0 deletions recipes-devtools/pyelftools/python3-pyelftools_git.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
inherit setuptools3
require python-pyelftools.inc

RDEPENDS_${PN} = "python3 python3-contextlib python3-debugger python3-pprint"
RDEPENDS_${PN}_class-native = "python3"

0 comments on commit cdb0fd7

Please sign in to comment.