Skip to content
This repository was archived by the owner on Oct 25, 2022. It is now read-only.

Commit

Permalink
gtk+3.bbappend: refresh patches
Browse files Browse the repository at this point in the history
fix:

Some of the context lines in patches were ignored. This can lead to
incorrectly applied patches.
The context lines in the patches can be updated with devtool:

    devtool modify <recipe>
    devtool finish --force-patch-refresh <recipe> <layer_path>

Then the updated patches and the source tree (in devtool's workspace)
should be reviewed to make sure the patches apply in the correct place
and don't introduce duplicate lines (which can, and does happen
when some of the context is ignored). Further information:
http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html
https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450
Details:
Applying patch
workaround-for-anaconda-installer-while-loading-libA.patch
patching file gtk/gtkbuilder.c
Hunk #1 succeeded at 402 (offset 4 lines).
Hunk #2 succeeded at 430 with fuzz 1 (offset 4 lines).

Now at patch workaround-for-anaconda-installer-while-loading-libA.patch

Signed-off-by: Hongxu Jia <[email protected]>
  • Loading branch information
hongxu-jia committed Mar 28, 2018
1 parent 46ba229 commit 951f71f
Showing 1 changed file with 7 additions and 8 deletions.
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
From a99480777c259c1ef0db3ac972abae348d930b41 Mon Sep 17 00:00:00 2001
From 1e579c886506039b2a9eb19e1a344c4849c3c5c8 Mon Sep 17 00:00:00 2001
From: Hongxu Jia <[email protected]>
Date: Fri, 9 Oct 2015 07:12:36 -0400
Subject: [PATCH] workaround for anaconda installer while loading
libAnacondaWidgets
Subject: [PATCH] workaround for anaconda installer while loading libAnacondaWidgets

Here is easy way to reproduce the failure:
...
Expand Down Expand Up @@ -38,10 +37,10 @@ Signed-off-by: Hongxu Jia <[email protected]>
1 file changed, 24 insertions(+)

diff --git a/gtk/gtkbuilder.c b/gtk/gtkbuilder.c
index f9599ab..8315638 100644
index 619aa07..f4ab291 100644
--- a/gtk/gtkbuilder.c
+++ b/gtk/gtkbuilder.c
@@ -398,6 +398,27 @@ type_name_mangle (const gchar *name)
@@ -402,6 +402,27 @@ type_name_mangle (const gchar *name)
}

static GType
Expand Down Expand Up @@ -69,7 +68,7 @@ index f9599ab..8315638 100644
_gtk_builder_resolve_type_lazily (const gchar *name)
{
static GModule *module = NULL;
@@ -405,6 +426,9 @@ _gtk_builder_resolve_type_lazily (const gchar *name)
@@ -409,6 +430,9 @@ _gtk_builder_resolve_type_lazily (const gchar *name)
gchar *symbol;
GType gtype = G_TYPE_INVALID;

Expand All @@ -78,7 +77,7 @@ index f9599ab..8315638 100644
+
if (!module)
module = g_module_open (NULL, 0);

--
1.9.1
1.8.3.1

0 comments on commit 951f71f

Please sign in to comment.