Skip to content

Commit

Permalink
layers: Convert to new override syntax
Browse files Browse the repository at this point in the history
Signed-off-by: Khem Raj <[email protected]>
  • Loading branch information
kraj authored and psaavedra committed Oct 27, 2021
1 parent 82bcce7 commit 773cc70
Show file tree
Hide file tree
Showing 34 changed files with 143 additions and 143 deletions.
4 changes: 2 additions & 2 deletions .gitlab-ci/template/include/local-common.conf
Original file line number Diff line number Diff line change
Expand Up @@ -22,8 +22,8 @@ BB_DISKMON_DIRS ??= "\
ABORT,${DL_DIR},100M,1K \
ABORT,${SSTATE_DIR},100M,1K \
ABORT,/tmp,10M,1K"
PACKAGECONFIG_append_pn-qemu-native = " sdl"
PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
PACKAGECONFIG:append:pn-qemu-native = " sdl"
PACKAGECONFIG:append:pn-nativesdk-qemu = " sdl"
CONF_VERSION = "1"

DL_DIR ?= "${BSPDIR}/downloads/"
Expand Down
6 changes: 3 additions & 3 deletions .gitlab-ci/template/include/local-wpe-qt.conf
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
PACKAGECONFIG_append_pn-wpewebkit = " qtwpe"
PACKAGECONFIG:append:pn-wpewebkit = " qtwpe"

IMAGE_INSTALL_append = " wpewebkit-qtwpe-qml-plugin qt-wpe-simple-browser"
IMAGE_INSTALL:append = " wpewebkit-qtwpe-qml-plugin qt-wpe-simple-browser"

IMAGE_INSTALL_append = " qtbase-dev qtbase-mkspecs qtbase-plugins qtbase-staticdev qttranslations-qtbase \
IMAGE_INSTALL:append = " qtbase-dev qtbase-mkspecs qtbase-plugins qtbase-staticdev qttranslations-qtbase \
qtdeclarative-dev qtdeclarative-mkspecs qtdeclarative-qmlplugins qtdeclarative-tools qtdeclarative-staticdev \
qtimageformats-dev qtimageformats-plugins \
qtscript-dev qtscript-mkspecs \
Expand Down
2 changes: 1 addition & 1 deletion .gitlab-ci/template/local.conf.sample
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
DISTRO ?= '##DISTRO##'
MACHINE ?= '##MACHINE##'

IMAGE_INSTALL_append = " wpewebkit cog"
IMAGE_INSTALL:append = " wpewebkit cog"

include presets/##PRESETS##.conf
include include/local-common.conf
Expand Down
8 changes: 4 additions & 4 deletions classes/ruby.bbclass
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
DEPENDS += " \
ruby-native \
"
RDEPENDS_${PN} += " \
RDEPENDS:${PN} += " \
ruby \
"

Expand Down Expand Up @@ -146,15 +146,15 @@ EXPORT_FUNCTIONS do_compile do_install

PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-dev"

FILES_${PN}-dbg += " \
FILES:${PN}-dbg += " \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/.debug \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/*/.debug \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/*/*/.debug \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/*/*/*/.debug \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions/*/*/*/*/*/.debug \
"

FILES_${PN} += " \
FILES:${PN} += " \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/cache \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/bin \
Expand All @@ -164,6 +164,6 @@ FILES_${PN} += " \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/plugins \
"

FILES_${PN}-doc += " \
FILES:${PN}-doc += " \
${libdir}/ruby/gems/${RUBY_GEM_VERSION}/doc \
"
2 changes: 1 addition & 1 deletion conf/include/devupstream.inc
Original file line number Diff line number Diff line change
Expand Up @@ -24,7 +24,7 @@

BBCLASSEXTEND += "devupstream:target"

python devupstream_virtclass_handler_prepend () {
python devupstream_virtclass_handler:prepend () {
uri = bb.fetch2.URI(d.getVar("SRC_URI").split()[0])
if uri.scheme == "git":
d.setVar("S", "${WORKDIR}/git")
Expand Down
10 changes: 5 additions & 5 deletions conf/include/webkit-bleeding.inc
Original file line number Diff line number Diff line change
Expand Up @@ -9,8 +9,8 @@ PREFERRED_VERSION_wpebackend-fdo = "1.8.1+gitAUTOINC+%"
PREFERRED_VERSION_wpebackend-rdk = "1.20180925+gitAUTOINC+%"
PREFERRED_VERSION_wpewebkit = "2.30.5+gitAUTOINC+%"

SRCREV_class-devupstream_pn-cog = "${AUTOREV}"
SRCREV_class-devupstream_pn-libwpe = "${AUTOREV}"
SRCREV_class-devupstream_pn-wpebackend-fdo = "${AUTOREV}"
SRCREV_class-devupstream_pn-wpebackend-rdk = "${AUTOREV}"
SRCREV_class-devupstream_pn-wpewebkit = "${AUTOREV}"
SRCREV:class-devupstream:pn-cog = "${AUTOREV}"
SRCREV:class-devupstream:pn-libwpe = "${AUTOREV}"
SRCREV:class-devupstream:pn-wpebackend-fdo = "${AUTOREV}"
SRCREV:class-devupstream:pn-wpebackend-rdk = "${AUTOREV}"
SRCREV:class-devupstream:pn-wpewebkit = "${AUTOREV}"
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@ LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1-or-later;md5=2a4f4fd2128ea2f65047ee63fbca9f68"

DEPENDS = "qtbase qtdeclarative"
RDEPENDS_${PN} = "wpewebkit wpewebkit-qtwpe-qml-plugin"
RDEPENDS:${PN} = "wpewebkit wpewebkit-qtwpe-qml-plugin"

SRC_URI = "file://CMakeLists.txt \
file://main.cpp \
Expand Down
4 changes: 2 additions & 2 deletions recipes-benchmark/browserperfrunner/browserperfrunner_git.bb
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ PACKAGES = "${PN}"

# Note: this recipe depends on meta-openembedded/meta-python for python-psutil
# And the dromaeo test needs the crc32 binary that is provided by libarchive-zip-perl
RDEPENDS_${PN} = " curl make patch perl procps psmisc python python-misc \
RDEPENDS:${PN} = " curl make patch perl procps psmisc python python-misc \
python-modules python-psutil python-setuptools \
gobject-introspection python-pygobject gtk+3 ruby \
subversion libarchive-zip-perl"
Expand All @@ -37,4 +37,4 @@ do_install() {
cp -dr --preserve=mode,timestamp ${S}/webkitpy ${D}${PYTHON_SITEPACKAGES_DIR}/
}

FILES_${PN} = "${bindir}/* ${PYTHON_SITEPACKAGES_DIR}/*"
FILES:${PN} = "${bindir}/* ${PYTHON_SITEPACKAGES_DIR}/*"
Original file line number Diff line number Diff line change
Expand Up @@ -12,7 +12,7 @@ S = "${WORKDIR}/Archive-Zip-${PV}"

# crc32 at least depends on perl-module-lib, perl-module-cwd, perl-module-zip* ...
# so let's just depend on the perl-modules meta-package for simplicity.
RDEPENDS_${PN} += "perl-modules"
RDEPENDS:${PN} += "perl-modules"

inherit cpan

Expand Down
8 changes: 4 additions & 4 deletions recipes-browser/cog/cog.inc
Original file line number Diff line number Diff line change
Expand Up @@ -18,12 +18,12 @@ DEPENDS = " \
libsoup-2.4 glib-2.0 wayland-native wayland-protocols \
"

DEPENDS_append_class-target = " \
DEPENDS:append:class-target = " \
${@bb.utils.contains('PACKAGECONFIG', 'fdo', 'wayland-native', '', d)} \
"

# At run-time cog package should depend on virtual/wpebackend unless webkitgtk+ is enabled.
RDEPENDS_${PN} += "\
RDEPENDS:${PN} += "\
${@bb.utils.contains('PACKAGECONFIG', 'webkitgtk', '', 'virtual/wpebackend', d)} \
xkeyboard-config \
"
Expand All @@ -42,12 +42,12 @@ FILES_SOLIBSDEV = "${libdir}/libcogcore*.so"

# cog < 0.10.0 installed D-Bus policy configuration into sysconfdir
# cog >= 0.10.0 installs it into datadir, see https://github.com/Igalia/cog/pull/296
FILES_${PN} += " \
FILES:${PN} += " \
${libdir}/libcogplatform*.so \
${sysconfdir}/dbus-1/system.d/com.igalia.Cog.conf \
${datadir}/dbus-1/system.d/com.igalia.Cog.conf \
"
INSANE_SKIP_${PN} = "dev-so"
INSANE_SKIP:${PN} = "dev-so"

# Local user name starting cog with DBus system session enabled. This should be
# set only if the dbus PACKAGECONFIG is enabled.
Expand Down
8 changes: 4 additions & 4 deletions recipes-browser/cog/cog_0.10.1.bb
Original file line number Diff line number Diff line change
Expand Up @@ -9,9 +9,9 @@ PACKAGECONFIG[headless] = "-DCOG_PLATFORM_HEADLESS=ON,-DCOG_PLATFORM_HEADLESS=OF
# Available from 0.12.X (future) or for devupstream (HEAD:master. Ref: https://github.com/Igalia/cog/commit/b595d12945148205af9da765cf05d092cbc234c4)
PACKAGECONFIG[wl] = "-DCOG_PLATFORM_WL=ON,-DCOG_PLATFORM_WL=OFF,wpebackend-fdo"

PACKAGECONFIG_class-devupstream ?= " ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/wpebackend', 'wpebackend-fdo', 'fdo wl drm', '', d)} "
PACKAGECONFIG:class-devupstream ?= " ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/wpebackend', 'wpebackend-fdo', 'fdo wl drm', '', d)} "

SRC_URI_class-devupstream = "git://github.com/Igalia/cog.git;protocol=https;branch=cog-0.10"
SRCREV_class-devupstream = "cfbbde0331e11b5b9ab5b4cc0749d55cf74b3d05"
SRC_URI:class-devupstream = "git://github.com/Igalia/cog.git;protocol=https;branch=cog-0.10"
SRCREV:class-devupstream = "cfbbde0331e11b5b9ab5b4cc0749d55cf74b3d05"

RDEPENDS_${PN} += "wpewebkit (>= 2.32)"
RDEPENDS:${PN} += "wpewebkit (>= 2.32)"
2 changes: 1 addition & 1 deletion recipes-browser/cog/cog_0.6.0.bb
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,4 @@ SRC_URI = "https://github.com/Igalia/cog/releases/download/v${PV}/cog-${PV}.tar.

SRC_URI[sha256sum] = "208f58e0533b269400875237a95e994c93da7234a29fd1c904e756b88963e35d"

RDEPENDS_${PN} += "wpewebkit (>= 2.28)"
RDEPENDS:${PN} += "wpewebkit (>= 2.28)"
2 changes: 1 addition & 1 deletion recipes-browser/cog/cog_0.8.1.bb
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,4 @@ require cog.inc

SRC_URI[sha256sum] = "b82e917eb764943b9859c631974f8f0e748b79ae87bb7a944f46c818740e0208"

RDEPENDS_${PN} += "wpewebkit (>= 2.28)"
RDEPENDS:${PN} += "wpewebkit (>= 2.28)"
4 changes: 2 additions & 2 deletions recipes-browser/libwpe/libwpe.inc
Original file line number Diff line number Diff line change
Expand Up @@ -9,9 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=371a616eb4903c6cb79e9893a5f615cc"
DEPENDS = "virtual/egl libxkbcommon"

PROVIDES += "virtual/libwpe"
RPROVIDES_${PN} += "virtual/libwpe"
RPROVIDES:${PN} += "virtual/libwpe"

# Workaround build issue with RPi userland EGL libraries.
CFLAGS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '-D_GNU_SOURCE', d)}"
CFLAGS:append:rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '-D_GNU_SOURCE', d)}"

inherit cmake
4 changes: 2 additions & 2 deletions recipes-browser/libwpe/libwpe_1.12.0.bb
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=371a616eb4903c6cb79e9893a5f615cc"

SRC_URI[sha256sum] = "e8eeca228a6b4c36294cfb63f7d3ba9ada47a430904a5a973b3c99c96a44c18c"

SRC_URI_class-devupstream = "git://github.com/WebPlatformForEmbedded/libwpe.git;protocol=https;branch=master"
SRCREV_class-devupstream = "e2a90a50857f4095de7e763cc6adc8540275ff49"
SRC_URI:class-devupstream = "git://github.com/WebPlatformForEmbedded/libwpe.git;protocol=https;branch=master"
SRCREV:class-devupstream = "e2a90a50857f4095de7e763cc6adc8540275ff49"

30 changes: 15 additions & 15 deletions recipes-browser/packagegroups/packagegroup-wpewebkit-depends.bb
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ PACKAGES = " \
packagegroup-wpewebkit-depends-tests \
"

RDEPENDS_packagegroup-wpewebkit-depends = "\
RDEPENDS:packagegroup-wpewebkit-depends = "\
packagegroup-wpewebkit-depends-sys-extended \
packagegroup-wpewebkit-depends-perl \
packagegroup-wpewebkit-depends-python \
Expand All @@ -31,7 +31,7 @@ RDEPENDS_packagegroup-wpewebkit-depends = "\
packagegroup-wpewebkit-depends-tests \
"

RDEPENDS_packagegroup-wpewebkit-depends-sys-extended = "\
RDEPENDS:packagegroup-wpewebkit-depends-sys-extended = "\
curl \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell', 'dhcp-client', 'dhcpcd', d)} \
hdparm \
Expand All @@ -46,7 +46,7 @@ RDEPENDS_packagegroup-wpewebkit-depends-sys-extended = "\
zip \
"

RDEPENDS_packagegroup-wpewebkit-depends-perl = "\
RDEPENDS:packagegroup-wpewebkit-depends-perl = "\
gdbm \
perl \
perl-modules \
Expand All @@ -56,7 +56,7 @@ RDEPENDS_packagegroup-wpewebkit-depends-perl = "\
zlib \
"

RDEPENDS_packagegroup-wpewebkit-depends-python = "\
RDEPENDS:packagegroup-wpewebkit-depends-python = "\
expat \
gdbm \
gmp \
Expand All @@ -67,7 +67,7 @@ RDEPENDS_packagegroup-wpewebkit-depends-python = "\
zip \
"

RDEPENDS_packagegroup-wpewebkit-depends-misc = "\
RDEPENDS:packagegroup-wpewebkit-depends-misc = "\
gettext \
gettext-runtime \
groff \
Expand All @@ -78,9 +78,9 @@ RDEPENDS_packagegroup-wpewebkit-depends-misc = "\
rpm \
"
STRACE = "strace"
STRACE_riscv32 = ""
STRACE:riscv32 = ""

RDEPENDS_packagegroup-wpewebkit-depends-core = "\
RDEPENDS:packagegroup-wpewebkit-depends-core = "\
at \
bash \
bc \
Expand Down Expand Up @@ -144,12 +144,12 @@ RDEPENDS_packagegroup-wpewebkit-depends-core = "\
${@bb.utils.contains('BBFILE_COLLECTIONS', 'security', 'libseccomp', '', d)} \
libicudata \
"
RDEPENDS_packagegroup-wpewebkit-depends-core_append_libc-glibc = "\
RDEPENDS:packagegroup-wpewebkit-depends-core:append:libc-glibc = "\
glibc \
glibc-utils \
localedef \
"
RDEPENDS_packagegroup-wpewebkit-depends-desktop = "\
RDEPENDS:packagegroup-wpewebkit-depends-desktop = "\
libxt \
libxxf86vm \
libdrm \
Expand All @@ -169,7 +169,7 @@ RDEPENDS_packagegroup-wpewebkit-depends-desktop = "\
alsa-lib \
"

RDEPENDS_packagegroup-wpewebkit-depends-runtime-add = "\
RDEPENDS:packagegroup-wpewebkit-depends-runtime-add = "\
ldd \
e2fsprogs-mke2fs \
mkfontdir \
Expand All @@ -178,7 +178,7 @@ RDEPENDS_packagegroup-wpewebkit-depends-runtime-add = "\
libxml-perl \
libxml-sax-perl \
"
RDEPENDS_packagegroup-wpewebkit-depends-runtime-add_append_libc-glibc = "\
RDEPENDS:packagegroup-wpewebkit-depends-runtime-add:append:libc-glibc = "\
glibc-localedatas \
glibc-gconvs \
glibc-charmaps \
Expand All @@ -188,7 +188,7 @@ RDEPENDS_packagegroup-wpewebkit-depends-runtime-add_append_libc-glibc = "\
glibc-pcprofile \
"

RDEPENDS_packagegroup-wpewebkit-depends-alternative = " \
RDEPENDS:packagegroup-wpewebkit-depends-alternative = " \
geoclue \
libtasn1 \
woff2 \
Expand All @@ -201,7 +201,7 @@ RDEPENDS_packagegroup-wpewebkit-depends-alternative = " \
openh264 \
"

RDEPENDS_packagegroup-wpewebkit-depends-video = " \
RDEPENDS:packagegroup-wpewebkit-depends-video = " \
gstreamer1.0 \
gstreamer1.0-plugins-base \
gstreamer1.0-plugins-good \
Expand Down Expand Up @@ -231,7 +231,7 @@ RDEPENDS_packagegroup-wpewebkit-depends-video = " \
gstreamer1.0-plugins-bad-videoparsersbad \
"

RDEPENDS_packagegroup-wpewebkit-depends-extra = " \
RDEPENDS:packagegroup-wpewebkit-depends-extra = " \
ca-certificates \
shared-mime-info \
ttf-dejavu-sans \
Expand All @@ -242,7 +242,7 @@ RDEPENDS_packagegroup-wpewebkit-depends-extra = " \
gstreamer1.0-plugins-bad-meta \
"

RDEPENDS_packagegroup-wpewebkit-depends-tests = " \
RDEPENDS:packagegroup-wpewebkit-depends-tests = " \
pkgconfig \
p7zip \
git \
Expand Down
Loading

0 comments on commit 773cc70

Please sign in to comment.