Skip to content

Commit

Permalink
Update recipes for development branches
Browse files Browse the repository at this point in the history
According to the Yocto documentation [1], the devupstream class uses
BBCLASSEXTEND to create a variant of the recipe that fetches sources
from an alternative URI (e.g., Git) instead of a tarball.

When building with devupstream, the sources fetched should match
those from the non-devupstream build, meaning the exact commit used
to generate the tarball release should be fetched.

- Update various SRCBRANCH and SRCREV fields for devupstream class:
  - Set 'master' as the default branch for pn-cog, pn-libwpe, and
    pn-wpebackend-fdo.
  - Change branch for pn-wpewebkit to 'main'.
- Modify cog recipe (cog_0.18.4.bb):
  - Use branch 'cog-0.18' instead of 'master'.
  - Update SRCREV to 'c4625676a21308e7c82175f1ce9a6c8849f22800'.
- Modify libwpe recipe (libwpe_1.16.0.bb):
  - Use branch 'libwpe-1.16'.
  - Update SRCREV to '782026ce4976a35e9343ba75aefe379b0d8428f7'.
- Modify wpebackend-fdo recipe (wpebackend-fdo_1.14.3.bb):
  - Use branch 'wpebackend-fdo-1.14'.
  - Update SRCREV to '04ccf2ef1753e72345770fb0a60bf38c5a100de8'.
- Remove outdated wpebackend-fdo_devupstream.bb file.
- Modify wpewebkit recipe (wpewebkit_2.46.1.bb):
  - Use branch 'webkitglib/2.46'.
  - Update SRCREV to 'eacf9977760d4ea5dfcb736be73ae48c7df16f27'.

[1] https://docs.yoctoproject.org/ref-manual/classes.html#ref-classes-devupstream
  • Loading branch information
psaavedra committed Oct 15, 2024
1 parent ccbaaa7 commit 2c8ca1d
Show file tree
Hide file tree
Showing 6 changed files with 24 additions and 17 deletions.
10 changes: 9 additions & 1 deletion conf/include/webkit-bleeding.inc
Original file line number Diff line number Diff line change
Expand Up @@ -9,8 +9,16 @@ PREFERRED_VERSION_wpebackend-fdo = "devupstream+gitAUTOINC+%"
PREFERRED_VERSION_wpebackend-rdk = "1.20200213+gitAUTOINC+%"
PREFERRED_VERSION_wpewebkit = "2.42+httpsAUTOINC+%"

SRCBRANCH:class-devupstream:pn-cog = "master"
SRCREV:class-devupstream:pn-cog = "${AUTOREV}"

SRCBRANCH:class-devupstream:pn-libwpe = "master"
SRCREV:class-devupstream:pn-libwpe = "${AUTOREV}"

SRCBRANCH:class-devupstream:pn-wpebackend-fdo = "master"
SRCREV:class-devupstream:pn-wpebackend-fdo = "${AUTOREV}"

SRCREV:class-devupstream:pn-wpebackend-rdk = "${AUTOREV}"

SRCBRANCH:class-devupstream:pn-wpewebkit = "main"
SRCREV:class-devupstream:pn-wpebackend-rdk = "${AUTOREV}"
SRCREV:class-devupstream:pn-wpewebkit = "${AUTOREV}"
6 changes: 3 additions & 3 deletions recipes-browser/cog/cog_0.18.4.bb
Original file line number Diff line number Diff line change
Expand Up @@ -4,9 +4,9 @@ require conf/include/devupstream.inc

SRC_URI[sha256sum] = "31d7079db2eeed790899d2f1f824dd6a54bf30d072d196d737be572f105d99b1"

SRC_URI:class-devupstream = "git://github.com/Igalia/cog.git;protocol=https;branch=master"
# Cog 0.18.X branch was forked from the master branch in this commit
SRCREV:class-devupstream = "8e1acd3704e22904acc2fee0d4a2f5344257434c"
SRCBRANCH:class-devupstream ?= "cog-0.18"
SRC_URI:class-devupstream = "git://github.com/Igalia/cog.git;protocol=https;branch=${SRCBRANCH}"
SRCREV:class-devupstream = "c4625676a21308e7c82175f1ce9a6c8849f22800"

RDEPENDS:${PN} += "wpewebkit (>= 2.42)"

5 changes: 3 additions & 2 deletions recipes-browser/libwpe/libwpe_1.16.0.bb
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,7 @@ require conf/include/devupstream.inc

SRC_URI[sha256sum] = "c7f3a3c6b3d006790d486dc7cceda2b6d2e329de07f33bc47dfc53f00f334b2a"

SRC_URI:class-devupstream = "git://github.com/WebPlatformForEmbedded/libwpe.git;protocol=https;branch=master"
SRCREV:class-devupstream = "f57050fbff7c88ed68f5799128c71e249e2783bd"
SRCBRANCH:class-devupstream ?= "libwpe-1.16"
SRC_URI:class-devupstream = "git://github.com/WebPlatformForEmbedded/libwpe.git;protocol=https;branch=${SRCBRANCH}"
SRCREV:class-devupstream = "782026ce4976a35e9343ba75aefe379b0d8428f7"

6 changes: 6 additions & 0 deletions recipes-browser/wpebackend-fdo/wpebackend-fdo_1.14.3.bb
Original file line number Diff line number Diff line change
@@ -1,3 +1,9 @@
require wpebackend-fdo.inc
require conf/include/devupstream.inc

SRC_URI[sha256sum] = "10121842595a850291db3e82f3db0b9984df079022d386ce42c2b8508159dc6c"

SRCBRANCH:class-devupstream ?= "wpebackend-fdo-1.14"
SRC_URI:class-devupstream = "git://github.com/Igalia/WPEBackend-fdo.git;protocol=https;branch=${SRCBRANCH}"
SRCREV:class-devupstream = "04ccf2ef1753e72345770fb0a60bf38c5a100de8"

8 changes: 0 additions & 8 deletions recipes-browser/wpebackend-fdo/wpebackend-fdo_devupstream.bb

This file was deleted.

6 changes: 3 additions & 3 deletions recipes-browser/wpewebkit/wpewebkit_2.46.1.bb
Original file line number Diff line number Diff line change
Expand Up @@ -9,9 +9,9 @@ SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz;name=tarball \

SRC_URI[tarball.sha256sum] = "1e0aaf870f36001c42b1ce5a2027b4101bed878746e437cc6d6fed0693afe9ad"

SRC_URI:class-devupstream = "git://github.com/WebKit/WebKit.git;protocol=https;branch=main"

SRCREV:class-devupstream = "8db1e051cf4a6d7877dd51b81b478e8367d3f052"
SRCBRANCH:class-devupstream = "webkitglib/2.46"
SRC_URI:class-devupstream = "git://github.com/WebKit/WebKit.git;protocol=https;branch=${SRCBRANCH}"
SRCREV:class-devupstream = "eacf9977760d4ea5dfcb736be73ae48c7df16f27"

# Experimental new WPE platform API
PACKAGECONFIG[experimental-wpe-platform] = "-DENABLE_WPE_PLATFORM=ON,-DENABLE_WPE_PLATFORM=OFF,libinput"
Expand Down

0 comments on commit 2c8ca1d

Please sign in to comment.