Skip to content

Commit 093b8ad

Browse files
committed
chore(rust): switch from nightly to stable 1.84.0
closes #132
1 parent 73f3f27 commit 093b8ad

File tree

6 files changed

+76
-76
lines changed

6 files changed

+76
-76
lines changed

packages/rust/proxy/Cargo.lock

+33-33
Some generated files are not rendered by default. Learn more about customizing how changed files appear on GitHub.

packages/rust/proxy/Cargo.toml

+1-1
Original file line numberDiff line numberDiff line change
@@ -20,7 +20,7 @@ futures = "0.3"
2020
itertools = "0.14"
2121
serde = { version = "1", features = ["derive"] }
2222
serde_json = "1"
23-
tangram_client = { default-features = false, git = "https://github.com/tangramdotdev/tangram", rev = "067268c2b6063f2f187c8b1268b409a04f5a0967" }
23+
tangram_client = { default-features = false, git = "https://github.com/tangramdotdev/tangram", rev = "aacfa4701ecc4ba4eae4a26112a6d9654eddb677" }
2424
tokio = { version = "1", default-features = false, features = [
2525
"rt",
2626
"fs",

packages/rust/tangram.ts

+3-3
Original file line numberDiff line numberDiff line change
@@ -20,6 +20,7 @@ export const metadata = {
2020
};
2121

2222
const PROFILE = "minimal" as const;
23+
const VERSION = "1.84.0" as const;
2324

2425
export type ToolchainArg = {
2526
host?: string;
@@ -44,10 +45,9 @@ export const toolchain = tg.target(async (arg?: ToolchainArg) => {
4445
}
4546

4647
// Download the Rust manifest for the selected version.
47-
const date = "2025-01-06";
4848
const manifestArtifact = await std.download({
49-
url: `https://static.rust-lang.org/dist/${date}/channel-rust-nightly.toml`,
50-
checksum: "unsafe",
49+
url: `https://static.rust-lang.org/dist/channel-rust-${VERSION}.toml`,
50+
checksum: "sha256:94c2c0ba9c6783815df45d680f0f20c7ea80d11b85ee8bbbc61354f3082cd0f5",
5151
decompress: false,
5252
extract: false,
5353
});

0 commit comments

Comments
 (0)