Skip to content

Commit fbead39

Browse files
authored
Update pyo3 and deps (#5)
1 parent de19bf3 commit fbead39

File tree

4 files changed

+43
-160
lines changed

4 files changed

+43
-160
lines changed

Cargo.lock

+39-156
Some generated files are not rendered by default. Learn more about customizing how changed files appear on GitHub.

Cargo.toml

+2-2
Original file line numberDiff line numberDiff line change
@@ -10,8 +10,8 @@ crate-type = ["cdylib"]
1010

1111
[dependencies]
1212
atoi = "2.0.0"
13-
base64 = "0.21.5"
13+
base64 = "0.22.1"
1414

1515
[dependencies.pyo3]
16-
version = "0.20.3"
16+
version = "0.23.1"
1717
features = ["extension-module"]

pyproject.toml

+1-1
Original file line numberDiff line numberDiff line change
@@ -4,7 +4,7 @@ build-backend = "maturin"
44

55
[project]
66
name = "meta-memcache-socket"
7-
requires-python = ">=3.7"
7+
requires-python = ">=3.10"
88
classifiers = [
99
"Programming Language :: Rust",
1010
"Programming Language :: Python :: Implementation :: CPython",

src/lib.rs

+1-1
Original file line numberDiff line numberDiff line change
@@ -146,7 +146,7 @@ pub fn build_meta_arithmetic(
146146
}
147147

148148
#[pymodule]
149-
fn meta_memcache_socket(_py: Python, module: &PyModule) -> PyResult<()> {
149+
fn meta_memcache_socket(module: &Bound<'_, PyModule>) -> PyResult<()> {
150150
module.add_class::<ResponseFlags>()?;
151151
module.add_class::<RequestFlags>()?;
152152
module.add_function(wrap_pyfunction!(parse_header, module)?)?;

0 commit comments

Comments
 (0)