Skip to content

Commit ab76411

Browse files
chromium: Fix gn build for Yocto master (#808)
Build and patch changes: ------------------------ Add one backported patch to fix a build error on Yocto master. License changes: ---------------- Added licenses: none. Removed licenses: none. Updated licenses: none. Test-built: ----------- * chromium-x11: - master, clang, MACHINE=qemuarm Signed-off-by: Max Ihlenfeldt <[email protected]>
1 parent d3a5f63 commit ab76411

File tree

2 files changed

+28
-0
lines changed

2 files changed

+28
-0
lines changed

meta-chromium/recipes-browser/chromium/gn-native_122.0.6261.128.bb

Lines changed: 1 addition & 0 deletions
Original file line numberDiff line numberDiff line change
@@ -16,6 +16,7 @@ B = "${S}/out_bootstrap"
1616

1717
SRC_URI += " \
1818
file://0001-Pass-no-static-libstdc-to-gen.py.patch \
19+
file://gn-bootstrap-Don-t-pass-removed-dupbuild-ninja-optio.patch \
1920
"
2021

2122
# The build system expects the linker to be invoked via the compiler. If we use
Lines changed: 27 additions & 0 deletions
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,27 @@
1+
From 3fbc984a8c73cb8245ea0c3783cb88c558996f7d Mon Sep 17 00:00:00 2001
2+
From: Max Ihlenfeldt <[email protected]>
3+
Date: Tue, 7 May 2024 17:38:25 +0200
4+
Subject: [PATCH] Backport "gn bootstrap: Don't pass removed dupbuild ninja option"
5+
6+
This backports a patch to GN's bootstrap script to fix a build error
7+
when using ninja >= 1.12.0. It will be included in upstream's 126
8+
release.
9+
10+
Upstream-Status: Backport [https://crrev.com/c/5522398]
11+
---
12+
tools/gn/bootstrap/bootstrap.py | 2 +-
13+
1 file changed, 1 insertion(+), 1 deletion(-)
14+
15+
diff --git a/tools/gn/bootstrap/bootstrap.py b/tools/gn/bootstrap/bootstrap.py
16+
index caf736b28946d..b721e79a205ed 100755
17+
--- a/tools/gn/bootstrap/bootstrap.py
18+
+++ b/tools/gn/bootstrap/bootstrap.py
19+
@@ -122,7 +122,7 @@ def main(argv):
20+
21+
shutil.copy2(
22+
os.path.join(BOOTSTRAP_DIR, 'last_commit_position.h'), gn_build_dir)
23+
- cmd = [ninja_binary, '-C', gn_build_dir, '-w', 'dupbuild=err', 'gn']
24+
+ cmd = [ninja_binary, '-C', gn_build_dir, 'gn']
25+
if options.jobs:
26+
cmd += ['-j', str(options.jobs)]
27+
subprocess.check_call(cmd)

0 commit comments

Comments
 (0)