Skip to content

Commit 61ad45c

Browse files
committed
Implement numpy on macos
1 parent 3d7425d commit 61ad45c

File tree

18 files changed

+641
-0
lines changed

18 files changed

+641
-0
lines changed
+11
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,11 @@
1+
import __np__
2+
import glob
3+
from typing import *
4+
5+
import os
6+
7+
8+
def run(temp_dir: str):
9+
__np__.download_extract("https://github.com/Kitware/CMake/releases/download/v3.31.4/cmake-3.31.4-macos-universal.tar.gz",
10+
temp_dir)
11+
__np__.install_build_tool("cmake", os.path.join(temp_dir, "cmake-3.31.4-macos-universal", "CMake.app", "Contents", "*"))
+8
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,8 @@
1+
{
2+
"version": "3.31.4",
3+
"build_tools": [],
4+
"files": [
5+
"build.py"
6+
],
7+
"build_script": "build.py"
8+
}
+11
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,11 @@
1+
import __np__
2+
import glob
3+
from typing import *
4+
5+
import os
6+
7+
8+
def run(temp_dir: str):
9+
__np__.download_extract("https://github.com/ninja-build/ninja/releases/download/v1.12.1/ninja-mac.zip",
10+
temp_dir)
11+
__np__.install_build_tool("ninja", os.path.join(temp_dir, "*"))
+8
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,8 @@
1+
{
2+
"version": "1.12.1",
3+
"build_tools": [],
4+
"files": [
5+
"build.py"
6+
],
7+
"build_script": "build.py"
8+
}
+30
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,30 @@
1+
import __np__
2+
from typing import *
3+
4+
import os
5+
import shutil
6+
import glob
7+
8+
9+
def run(temp_dir: str):
10+
__np__.download_extract("https://github.com/OpenMathLib/OpenBLAS/releases/download/v0.3.28/OpenBLAS-0.3.28.zip", temp_dir)
11+
12+
src_dir = glob.glob(os.path.join(temp_dir, "OpenBLAS*"))[0]
13+
14+
install_dir = os.path.join(temp_dir, "install")
15+
os.mkdir(install_dir)
16+
build_dir = os.path.join(temp_dir, "build")
17+
os.mkdir(build_dir)
18+
os.chdir(build_dir)
19+
20+
env = os.environ.copy()
21+
env["MACOSX_DEPLOYMENT_TARGET"] = "10.9"
22+
__np__.run_build_tool_exe("cmake", "cmake", "-DCMAKE_BUILD_TYPE=Release",
23+
"-DCMAKE_INSTALL_PREFIX=" + install_dir, "-DBUILD_STATIC_LIBS=ON", "-DBUILD_SHARED_LIBS=OFF",
24+
"-DBUILD_TESTING=OFF", src_dir, env=env)
25+
__np__.run_with_output("make", "-j4", "install", env=env)
26+
27+
__np__.install_dep_libs("openblas", os.path.join(install_dir, "lib", "*"),
28+
base_dir=os.path.join(install_dir, "lib"))
29+
__np__.install_dep_include("openblas", os.path.join(install_dir, "include", "*"),
30+
base_dir=os.path.join(install_dir, "include"))
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,11 @@
1+
{
2+
"version": "0.3.28",
3+
"build_tools": [
4+
"cmake"
5+
],
6+
"dependencies": [ ],
7+
"files": [
8+
"build.py"
9+
],
10+
"build_script": "build.py"
11+
}

packages/np311-macos/cffi/build.py

+17
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
import __np__
2+
import glob
3+
import shutil
4+
import sys
5+
import os
6+
7+
8+
def run(wheel_directory):
9+
__np__.run_with_output("patch", "--binary", "-p1", "-i",
10+
os.path.join(os.path.dirname(__file__), "cffi-static-patch.patch"))
11+
12+
__np__.run_with_output(sys.executable, "setup.py", "bdist_wheel")
13+
14+
wheel_location = glob.glob(os.path.join("dist", "cffi-*.whl"))[0]
15+
wheel_name = os.path.basename(wheel_location)
16+
shutil.copy(wheel_location, os.path.join(wheel_directory, wheel_name))
17+
return os.path.join(wheel_directory, wheel_name)
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,25 @@
1+
diff --git a/setup.py b/setup.py
2+
index 008d575..b4cf622 100644
3+
--- a/setup.py
4+
+++ b/setup.py
5+
@@ -144,13 +144,16 @@ if sys.platform == "win32" and uses_msvc():
6+
sources.extend(os.path.join(COMPILE_LIBFFI, filename)
7+
for filename in _filenames)
8+
else:
9+
- use_pkg_config()
10+
+ #use_pkg_config()
11+
+ import __np__
12+
+ include_dirs.append(__np__.find_dep_include('base'))
13+
+ library_dirs.append(__np__.find_dep_libs('base'))
14+
ask_supports_thread()
15+
ask_supports_sync_synchronize()
16+
17+
-if 'darwin' in sys.platform:
18+
- # priority is given to `pkg_config`, but always fall back on SDK's libffi.
19+
- extra_compile_args += ['-iwithsysroot/usr/include/ffi']
20+
+#if 'darwin' in sys.platform:
21+
+# # priority is given to `pkg_config`, but always fall back on SDK's libffi.
22+
+# extra_compile_args += ['-iwithsysroot/usr/include/ffi']
23+
24+
if 'freebsd' in sys.platform:
25+
include_dirs.append('/usr/local/include')

packages/np311-macos/cffi/index.json

+19
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,19 @@
1+
{
2+
"scripts": [
3+
{
4+
"metadata": {
5+
"Version": "*"
6+
},
7+
"build_tools": [],
8+
"dependencies": [],
9+
"files": [
10+
"build.py",
11+
"cffi-static-patch.patch"
12+
],
13+
"requires": [
14+
"setuptools"
15+
],
16+
"build_script": "build.py"
17+
}
18+
]
19+
}
+18
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,18 @@
1+
import __np__
2+
import glob
3+
import shutil
4+
import sys
5+
import os
6+
import setuptools.build_meta
7+
8+
9+
def run(wheel_directory):
10+
__np__.run_with_output("patch", "-t", "-p1", "-i",
11+
os.path.join(os.path.dirname(__file__), "meson_python-static-patch.patch"))
12+
13+
__np__.run_with_output(sys.executable, "-m", "pip", "wheel", ".", "--verbose")
14+
15+
wheel_location = glob.glob("meson_python-*.whl")[0]
16+
wheel_name = os.path.basename(wheel_location)
17+
shutil.copy(wheel_location, os.path.join(wheel_directory, wheel_name))
18+
return os.path.join(wheel_directory, wheel_name)
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,20 @@
1+
{
2+
"scripts": [
3+
{
4+
"metadata": {
5+
"Version": "*"
6+
},
7+
"build_tools": [],
8+
"dependencies": [],
9+
"files": [
10+
"build.py",
11+
"meson_python-static-patch.patch"
12+
],
13+
"requires": [
14+
"setuptools",
15+
"meson"
16+
],
17+
"build_script": "build.py"
18+
}
19+
]
20+
}
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,42 @@
1+
diff --git a/mesonpy/__init__.py b/mesonpy/__init__.py
2+
index 4d785a3..10f28db 100644
3+
--- a/mesonpy/__init__.py
4+
+++ b/mesonpy/__init__.py
5+
@@ -75,7 +75,7 @@ _MESON_ARGS_KEYS = ['dist', 'setup', 'compile', 'install']
6+
7+
_SUFFIXES = importlib.machinery.all_suffixes()
8+
_EXTENSION_SUFFIX_REGEX = re.compile(r'^[^.]+\.(?:(?P<abi>[^.]+)\.)?(?:so|pyd|dll)$')
9+
-assert all(re.match(_EXTENSION_SUFFIX_REGEX, f'foo{x}') for x in importlib.machinery.EXTENSION_SUFFIXES)
10+
+#assert all(re.match(_EXTENSION_SUFFIX_REGEX, f'foo{x}') for x in importlib.machinery.EXTENSION_SUFFIXES)
11+
12+
# Map Meson installation path placeholders to wheel installation paths.
13+
# See https://docs.python.org/3/library/sysconfig.html#installation-paths
14+
@@ -345,7 +345,8 @@ class _WheelBuilder():
15+
# distribute any file in {platlib}) thus use generic
16+
# implementation and ABI tags.
17+
return mesonpy._tags.Tag('py3', 'none', None)
18+
- return mesonpy._tags.Tag(None, self._stable_abi, None)
19+
+ import packaging
20+
+ return list(packaging.tags.generic_tags())[0]
21+
22+
@property
23+
def name(self) -> str:
24+
@@ -409,7 +410,7 @@ class _WheelBuilder():
25+
# ABI, therefore extension modules using the limited API do
26+
# not use the stable ABI filename suffix and wheels should not
27+
# be tagged with the abi3 tag.
28+
- if self._limited_api and '__pypy__' not in sys.builtin_module_names:
29+
+ if self._limited_api and '__pypy__' not in sys.builtin_module_names and sys.implementation.name != 'nuitkapython':
30+
# Verify stable ABI compatibility: examine files installed
31+
# in {platlib} that look like extension modules, and raise
32+
# an exception if any of them has a Python version
33+
@@ -785,7 +786,8 @@ class Project():
34+
# default build options
35+
'-Dbuildtype=release',
36+
'-Db_ndebug=if-release',
37+
- '-Db_vscrt=md',
38+
+ '-Db_vscrt=mt',
39+
+ '-Dprefer_static=True',
40+
# user build options
41+
*self._meson_args['setup'],
42+
# pass native file last to have it override the python

packages/np311-macos/meson/build.py

+19
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,19 @@
1+
import __np__
2+
import glob
3+
import shutil
4+
import sys
5+
import os
6+
import setuptools.build_meta
7+
8+
9+
def run(wheel_directory):
10+
__np__.run_with_output("patch", "-t", "-p1", "-i",
11+
os.path.join(os.path.dirname(__file__), "meson-static-patch.patch"))
12+
13+
os.environ["PEP517_BACKEND_PATH"] = os.pathsep.join([x for x in sys.path if not x.endswith(os.path.sep + "site")])
14+
__np__.run_with_output(sys.executable, "-m", "pip", "wheel", ".", "--verbose")
15+
16+
wheel_location = glob.glob("meson-*.whl")[0]
17+
wheel_name = os.path.basename(wheel_location)
18+
shutil.copy(wheel_location, os.path.join(wheel_directory, wheel_name))
19+
return os.path.join(wheel_directory, wheel_name)

packages/np311-macos/meson/index.json

+19
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,19 @@
1+
{
2+
"scripts": [
3+
{
4+
"metadata": {
5+
"Version": "*"
6+
},
7+
"build_tools": [],
8+
"dependencies": [],
9+
"files": [
10+
"build.py",
11+
"meson-static-patch.patch"
12+
],
13+
"requires": [
14+
"setuptools"
15+
],
16+
"build_script": "build.py"
17+
}
18+
]
19+
}
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,104 @@
1+
diff --git a/mesonbuild/build.py b/mesonbuild/build.py
2+
index cf71dc2..423b008 100644
3+
--- a/mesonbuild/build.py
4+
+++ b/mesonbuild/build.py
5+
@@ -2169,7 +2169,10 @@ class StaticLibrary(BuildTarget):
6+
elif self.rust_crate_type == 'staticlib':
7+
self.suffix = 'a'
8+
else:
9+
- self.suffix = 'a'
10+
+ if self.environment.machines[self.for_machine].is_windows():
11+
+ self.suffix = 'lib'
12+
+ else:
13+
+ self.suffix = 'a'
14+
self.filename = self.prefix + self.name + '.' + self.suffix
15+
self.outputs[0] = self.filename
16+
17+
@@ -2233,6 +2236,8 @@ class SharedLibrary(BuildTarget):
18+
environment: environment.Environment,
19+
compilers: T.Dict[str, 'Compiler'],
20+
kwargs):
21+
+ raise NotImplementedError("SharedLibrary builds not allowed on Nuitka-Python!")
22+
+
23+
self.soversion: T.Optional[str] = None
24+
self.ltversion: T.Optional[str] = None
25+
# Max length 2, first element is compatibility_version, second is current_version
26+
diff --git a/mesonbuild/cmake/toolchain.py b/mesonbuild/cmake/toolchain.py
27+
index 9eb961c..ffa9f89 100644
28+
--- a/mesonbuild/cmake/toolchain.py
29+
+++ b/mesonbuild/cmake/toolchain.py
30+
@@ -174,6 +174,8 @@ class CMakeToolchain:
31+
32+
# Set the compiler variables
33+
for lang, comp_obj in self.compilers.items():
34+
+ if lang == 'cython':
35+
+ continue
36+
prefix = 'CMAKE_{}_'.format(language_map.get(lang, lang.upper()))
37+
38+
exe_list = comp_obj.get_exelist()
39+
@@ -210,7 +212,7 @@ class CMakeToolchain:
40+
# Generate the CMakeLists.txt
41+
mlog.debug('CMake Toolchain: Calling CMake once to generate the compiler state')
42+
languages = list(self.compilers.keys())
43+
- lang_ids = [language_map.get(x, x.upper()) for x in languages]
44+
+ lang_ids = [language_map.get(x, x.upper()) for x in languages if x != 'cython']
45+
cmake_content = dedent(f'''
46+
cmake_minimum_required(VERSION 3.10)
47+
project(CompInfo {' '.join(lang_ids)})
48+
diff --git a/mesonbuild/dependencies/python.py b/mesonbuild/dependencies/python.py
49+
index 326e605..aa19f83 100644
50+
--- a/mesonbuild/dependencies/python.py
51+
+++ b/mesonbuild/dependencies/python.py
52+
@@ -217,7 +217,7 @@ class _PythonDependencyBase(_Base):
53+
verdot = self.variables.get('py_version_short')
54+
imp_lower = self.variables.get('implementation_lower', 'python')
55+
if self.static:
56+
- libpath = Path('libs') / f'libpython{vernum}.a'
57+
+ libpath = Path('libs') / f'python{vernum}.lib'
58+
else:
59+
if limited_api:
60+
vernum = vernum[0]
61+
diff --git a/mesonbuild/modules/python.py b/mesonbuild/modules/python.py
62+
index 1b7a056..198aa30 100644
63+
--- a/mesonbuild/modules/python.py
64+
+++ b/mesonbuild/modules/python.py
65+
@@ -10,7 +10,7 @@ from . import ExtensionModule, ModuleInfo
66+
from .. import mesonlib
67+
from .. import mlog
68+
from ..options import UserFeatureOption
69+
-from ..build import known_shmod_kwargs, CustomTarget, CustomTargetIndex, BuildTarget, GeneratedList, StructuredSources, ExtractedObjects, SharedModule
70+
+from ..build import known_shmod_kwargs, CustomTarget, CustomTargetIndex, BuildTarget, GeneratedList, StructuredSources, ExtractedObjects, SharedModule, StaticLibrary
71+
from ..dependencies import NotFoundDependency
72+
from ..dependencies.detect import get_dep_identifier, find_external_dependency
73+
from ..dependencies.python import BasicPythonExternalProgram, python_factory, _PythonDependencyBase
74+
@@ -230,7 +230,7 @@ class PythonInstallation(_ExternalProgramHolder['PythonExternalProgram']):
75+
(self.is_pypy or mesonlib.version_compare(self.version, '>=3.9')):
76+
kwargs['gnu_symbol_visibility'] = 'inlineshidden'
77+
78+
- return self.interpreter.build_target(self.current_node, args, kwargs, SharedModule)
79+
+ return self.interpreter.build_target(self.current_node, args, kwargs, StaticLibrary)
80+
81+
def _convert_api_version_to_py_version_hex(self, api_version: str, detected_version: str) -> str:
82+
python_api_version_format = re.compile(r'[0-9]\.[0-9]{1,2}')
83+
diff --git a/mesonbuild/modules/python3.py b/mesonbuild/modules/python3.py
84+
index 2e6779a..20068d6 100644
85+
--- a/mesonbuild/modules/python3.py
86+
+++ b/mesonbuild/modules/python3.py
87+
@@ -10,7 +10,7 @@ from .. import mesonlib
88+
from . import ExtensionModule, ModuleInfo
89+
from ..build import (
90+
BuildTarget, CustomTarget, CustomTargetIndex, ExtractedObjects,
91+
- GeneratedList, SharedModule, StructuredSources, known_shmod_kwargs
92+
+ GeneratedList, SharedModule, StaticLibrary, StructuredSources, known_shmod_kwargs
93+
)
94+
from ..interpreter.type_checking import SHARED_MOD_KWS
95+
from ..interpreterbase import typed_kwargs, typed_pos_args, noPosargs, noKwargs, permittedKwargs
96+
@@ -53,7 +53,7 @@ class Python3Module(ExtensionModule):
97+
suffix = []
98+
kwargs['name_prefix'] = ''
99+
kwargs['name_suffix'] = suffix
100+
- return self.interpreter.build_target(state.current_node, args, kwargs, SharedModule)
101+
+ return self.interpreter.build_target(state.current_node, args, kwargs, StaticLibrary)
102+
103+
@noPosargs
104+
@noKwargs

0 commit comments

Comments
 (0)